HomeGuide Archives:: Worldox GX4FAQSMinimum system requirements - Worldox Cloud

40.1. Minimum system requirements - Worldox Cloud

Cloud User Workstations

The Worldox executable is mirrored from the cloud to the workstations' local disks and launched from the local disk.

  • Processor: Core 2 Duo (or higher)
  • Operating System: Microsoft Windows XP Professional SP3, Vista and Windows 7, 8 or 10 (Home version O/S's not supported)
  • Memory:  Min 2 Gig of RAM or higher 4 Gig recommended for Win 7 and 8
  • MS Office 2007 through 2016 - 32-bit versions of full installs, for more information regerading Office 365, please see:  Worldox Compatibility with Office 365 (Click-To-Run installs and 64-bit versions are not supported)
  • Integration with Adobe Acrobat 7.0 or higher is supported (versions 6 and below of Acrobat are not supported)
  • Integration with Adobe Reader 8.0 or higher is supported (versions 7 and below of Reader are not supported)

Hosted Exchange

  • If you are running hosted Exchange, you must run Outlook in cached mode.


This page was: Helpful | Not Helpful

© 2012 Trumpet, Inc., All Rights Reserved